Errors when running reports

Sometimes you may get error when running reports such as:

  1. Initiate grid error;
  2. Grid display error;
  3. You are seeing "old" data (i.e. changes not reflected in reports which are apparent in the live data)

When this happens it is usually due to a caching issue whereby previous report data is being cached and the report is showing the old version of data. To overcome this we recommend you clear your cache but, in some browsers this is often not sufficient.

In those scenarios where clearing your cache does not work, it is possible to force the report to load the most recent data by changing the URL of the report (the address in the address bar in your browser).

To do so you need to append "?restore_session=1" (without the quotes) to the URL.

For example if you are viewing the Timeoff balance report the URL normally would be https://www.naturalhr.net/hr/reporting/timeoff-balance

To implement this refresh you need to change the URL to read https://www.naturalhr.net/hr/reporting/timeoff-balance?restore_session=1

Alternatively, there is a button entitled "Refresh" which will refresh the current report. 

Please note, you will then need to either reload the report or remove the restore_session=1 variable manually from the URL or via clicking the icon again otherwise grouping, saving and so on will not work correctly whilst the variable is appended to the URL.

Have more questions? Submit a request

1 Comments

  • 0
    Avatar
    Claire Fiddes

    I have tried both of the suggestions but my Timeoff off in lieu (TOIL) balance report is still just returning a blank screen. There aren't even any heading showing - it's as if the report just doesn't exist.  Is there an issue with that report at the moment or have I done something wrong?  I have been using it fine for the last week.

Please sign in to leave a comment.
Powered by Zendesk